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This tutorial shows examples of how to set footswitch functions on your MFC, using the editor application.  We'll 
cover these topics: 
 

1. Setting up a patch and effect footswitch from start to end 
2. Setting up a complete footswitch layout 
3. Advanced footswitch options 

 
Work through each of the steps below to get to know how to use the editor and set up your footswitches. 

Setting up a Patch and Effect Footswitch from Start to End 
 
For this tutorial, started the editor and select you’re the TB-11P model.  The Footswitches tab will already be 
selected, showing the footswitch layout of the TB-11P.  Note that the pedal button here refers to the footswitch 
UNDER the pedal, and not to the pedal itself. 

 
 

 
 



Click one of the buttons to start, and you'll see a popup menu giving you a choice between 4 different footswitch 
types: 

 

 PATCH - allows you to choose a patch from the current bank 

 EFFECT - allows you to set a footswitch to control effects or relays 

 BANK - has various choices to change the current bank 

 PAGE - is used to switch between different footswitch pages  
 

We'll click on button 3, then click "effect" on the menu, and choose Effect 2.  You have now assigned Effect 2 to 
footswitch 3: 
 

 
 
 

To make Effect 2 do something, we'll click on the Effects tab, and then use the scroll bar to select Effect 2.  On this 

page, we'll check the top "CC Number" and set a CC number (25 in the example below).  The most common 

values for off and on are 0 and 127.  Of course, you will need to read the documentation for the device you're 

controlling to know what these numbers need to be. 

If you wish, you can give the effect a name and abbreviation.  Leave the other options as they're shown below for 

now.  You can read more about those options in the user guide. 

And that's it.  You could save these settings and load them into your TB-11P, and use footswitch 3 to turn an 

effect off and on. 

 



 

 

  



Now we'll move on to setting up a patch footswitch. 

Go back to the Footswitches tab, click on button 7, then on the menu select Patch, then Patch 1.  Your footswitch 

tab should now look like this: 

 

 

To make the patch footswitch, we'll go to the MFC Patches tab.   

The first time you use this tab, you may wish to make some once-only selections.  Think about how many patches 

you need.  Let's say we need 12 patches, and we'll set up 4 footswitches to select patches 1, 2, 3, and 4.  That 

means we'll need 3 banks: A, B and C. 

So the first thing to do will be to limit Bank Up and Down to banks A, B and C. 

You might like to give the banks a name, so type in a name for Bank A.  Then you'll need to use the scrollbar to 

get to a patch in the next bank, Bank B.  A quick way to get there is to click to the right of the slider on the scroll 

bar.  This advances 10 patches to go straight to the next bank.  So you can now name bank B, and do the same to 

name bank C if you wish. 

Getting back to our footswitch, we set up button 7 to select patch 1.  And we will be using 3 banks, so this means 

we need to set up patches A1, B1, and C1.  Use the slider to select patch A1 and set a MIDI patch number to send 

for this patch.  This example sends MIDI program 1 for MFC patch A1: 



 

Now do the same for patches B1 and C1.  You can also set the initial effects states for up to 9 effects if you've 

already planned your effects and which ones you want off and on when you select the patch.  Or you can come 

back later to set them up. 

  



We now have an effect and a patch set up, but no way to change banks yet.  We'll add bank up and bank down 

footswitches. 

Go back to the Footswitches tab and click button 6, then select Bank, Bank Up.  Click button 1 then select Bank, 

Bank Down.  There's nothing else you need to set up with bank footswitches.  They select a bank (in this example, 

limited to banks A to C), and the patch footswitch will select patch 1 in the current bank. 

Your footswitch layout should now look like this: 

 

  



Setting up a Complete Footswitch Layout 
 

We'll now finish the footswitch layout with additional patches and effects.  See if you can get your footswitch 
layout to look like this: 
 

 
 

  



We'll now set up footswitch 5 to go to another page.  And we'll also put a page indicator LED on the footswitch so 
we can see which page we're on. 
 
Click button 5, choose Page, Page 2 on the menu. 
 
Then click button 5 again, and choose Page LED, Red on the menu. 
 
Your footswitch layout should now look like this: 
 

 
 
 
Now click on the Page 2 tab, and we'll set up a second page of footswitches. 
 
The first thing to do is make sure you have a way to get back to page 1.  Well use button 5 again, and indicate this 
page with a yellow flashing LED. 
 
Click button 5 and choose Page, Page 1.  Then click on button 5 again and choose Page LED, Yellow.  Now click on 
button 5 again and choose Page LED, Flashing.  Page 2 should now look like this: 
 



 
 
 
For this example, we'll make page 2 for selecting effects, including the same effects that were available on page 
1.  Set up your page 2 to look like this example: 



 
 
 
Now that we have a complete footswitch layout, it would be a good time to save these settings using the toolbar, 
or with the File menu, Save. 
 
We'll also need to make settings for all of the patches we're using on the MFC Patches tab, and for all of the 
effects we're using on the Effects tab. 
 
See the user guide for information about settings on other tabs. 
 
 
MOVING FOOTSWITCHES 
 
You may have noticed while adding footswitches that the menus prevent you having more than one of the same 
footswitch on the same page.  This means that if you want to move or swap footswitches, you'll need to set some 
footswitches back to "None" before making new selections. 
 
 
SUMMARY 
 
Basic mode should give most players what they need for a flexible MFC.  Remember: simple is often best, 
particularly in a live situation.  But if you want more, read on for advanced footswitch options.  



Advanced Footswitch Options 
 
Select Advanced Options on the toolbar.  Tin addition to other editor features, the footswitch menus will allow you 
to choose 2 functions for some MFC footswitches. 
 

 A Patch footswitch can have a 2nd patch number so you can toggle between 2 patches 

 A footswitch can also go to another page 

 Patch and Bank footswitches can have "and hold for …" options to always activate the main function, and 
optionally go to another page if you hold down the footswitch. 

 Patch, Bank and Page footswitches can have "or hold for …" options to select a different bank or page.  So a 
quick press activates the main function, or you hold the footswitch down for the 2nd function instead. 

 
There are also some new footswitch types available: 
 

 The Patch menu has a "Select" option so you can select any specific patch, such as A3, B7, J2, etc. 

 The Effects menu has a "Set Relays" option so you can select any relay combination you want 

 The Effects menu has a "Send MIDI" option which uses library books to send any MIDI message(s) you want.  
There are also options to have this footswitch act as a toggle or momentary effect footswitch 
 

 

 
 

 
 



Note that footswitch LEDs are shown for the first function (with the exception of 2nd patches).  For example, if you 
have a footswitch that has Bank A for the 1st function and Bank B for the 2nd function, the LED will show only for the 
first function.  It will light YELLOW if the current bank is Bank A. 
 
We'll now look at each of the advanced options. 
 
 

2ND PATCH 
 
If your main function is a patch, you can choose a 2nd patch as well. This allows you to switch between 2 different 
patches on the same footswitch.  It means that sometimes you may need to double-click a footswitch to select the 
patch you want, and this is handled automatically so that backtracking works as you expect. 
 
For footswitches with 2 patches, the LED shows RED for the 1st patch, and YELLOW if the 2nd patch is selected. 
 
Here's a patch footswitch with 1st and 2nd patches: 
 

 
 
 
  



ALSO GO TO … 
 
This option means your footswitch performs both the 1st and 2nd actions.  The 2nd action goes to a page.  Here are 
a couple of examples: 
 

 
 
When you choose one of the options, a brief explanation is also shown. 
 
 
  



AND HOLD FOR … 
 
Patch and Bank footswitches can have "and hold for …" options to always activate the main function, and optionally 
select the 2nd function as well, if you hold down the footswitch.  Here's how it works: 
 

 When you PRESS the footswitch, the main function will activate 

 If you then hold the footswitch down for about one second, the 2nd function will be activated as well 
 
Here are a couple of examples: 
 

 
 
Note that even though you can't duplicate the first function on the same page, you can have the same second 
function on the same page.  This example shows 2 footswitches with Page 2 as a second function. 
  



OR HOLD FOR … 
 
Patch, Bank and Page footswitches can have "or hold for …" options to select a different bank or page.  This option 
lets you use one footswitch for two different functions. Here's how it works: 
 

 If you press and release the footswitch within about one second, the main function will activate when you 
RELEASE the footswitch. 

  If you press and hold the footswitch down for about one second, the 2nd function will be activated 
INSTEAD.  

 
Here are a couple of examples: 
 

 
 
 
 
 



PATCH SELECT 
 
This option on the patch menu allows you to select any specific patch, by selecting both the bank and patch number.  
There's also an option to change to the selected bank as well.  Choose "Select …" on the patch menu, and you'll see 
this window: 
 

 
 
Check "Set Bank Also" if you want to change banks, then click on the patch you want.  When you select your patch, 
you'll see it assigned to the footswitch like this example on footswitch 9: 
 



 
 

  



SET RELAYS 
 
This option on the effects menu allows you to select any combination of relay states.  Choose "Set Relays …" on the 
effects menu, and you'll see this window: 
 

 
 
You can select each relay to not change, turn OFF or turn ON.  Normally, relay states are NOT changed when you 
select a patch, however, if you want to set relays with a patch change, you can do that on the Patch Select tab in 
advanced mode.   Here's an example of relay settings; a number shows for ON, an X for OFF and a dot for no change: 
 

 
 
 



SEND MIDI 
 
Any MIDI message(s) can be sent with this footswitch.  You can turn effects on and off, select patches, send 
messages to multiple devices, and so on.  It uses Library books numbered from 1 to 250.  Each book can contain MIDI 
messages as well as MFC commands to set the bank, change page and more.  You read more about the library books 
in the Library Tutorial. 
 
Select "Send MIDI …" on the effects menu and you'll see this window: 
 

 
 
There are 3 footswitch types: 

 Select: just sends the library book messages whenever you press the footswitch 

 Toggle: sends the library book messages when you press the footswitch and turns on.  The next press sends 
messages in the next higher library book (number 7 in this example) and turns off. 

 Momentary: sends the library book messages when you press the footswitch and turns on.  When you 
release the footswitch it sends messages in the next higher library book (number 7 in this example) and 
turns off. 

 
Here's an example of Send MIDI on footswitch 4: 
 



 
 
 
  



SEND MIDI GROUPS 
 
Send MIDI footswitches allow you to send any Library book.  Send MIDI is on the Effects sub-menu in Advanced 

mode.  You can place the footswitch into a red, green or yellow group.  It still sends the library book as normal, but 

the footswitch LED lights for the last pressed footswitch in the group.  This is useful for scene selection on the Axe-

FX.  See the section at the end of this document for tips on using this function. 

 

 

 

 

Page Name and Page Bank 
 
Each footswitch page can have a name up to 5 characters long, but naming a page will hide some effect states on the 
MFC display.   
 
You can also set a bank for MFC pages.  This could be useful for pages with patch select footswitches.  You can still 
change banks provided you use bank change footswitches on this same page. 
 

Summary 
 
Hopefully these examples help with the many available footswitch options and promote some ideas on how you 
could set up your own MFC.  This also demonstrates how important it is to keep a simple layout for live 
performances.  I don't think I'd want to use the footswitches we've set up in this tutorial! 
 
 
 
 
 


